[users] vlc installation and rebuild problem

Dries Verachtert dries at ulyssis.org
Sat Oct 18 21:36:27 CEST 2008


On Friday 17 October 2008 02:55:22 pm Boris Folgmann wrote:
> Hi,
>
> I hat to rpm -e vlc to be able to successfully perform yum upgrade in the
> last weeks. My system is CentOS 4.7. Of course I want vlc back, but get
> this errors on yum install vlc:
>
> Error: Missing Dependency: libdirectfb-1.0.so.0 is needed by package vlc
> Error: Missing Dependency: libfusion-1.0.so.0 is needed by package vlc
> Error: Missing Dependency: libdirect-1.0.so.0 is needed by package vlc
>
> I downloaded the SRPM, and tried rpmbuild --rebuild vlc-0.8.6i-1.rf.src.rpm
> but get this failed build dependencies:
>         avahi-devel is needed by vlc-0.8.6i-1.rf.i386
>         libXt-devel is needed by vlc-0.8.6i-1.rf.i386
>         libXv-devel is needed by vlc-0.8.6i-1.rf.i386
>         libXinerama-devel is needed by vlc-0.8.6i-1.rf.i386
>         libXxf86vm-devel is needed by vlc-0.8.6i-1.rf.i386
>         jack-audio-connection-kit-devel is needed by vlc-0.8.6i-1.rf.i386
>         lirc-devel is needed by vlc-0.8.6i-1.rf.i386
>         libsysfs-devel is needed by vlc-0.8.6i-1.rf.i386
>
> All of which are not installable using yum. :-(

If you want to rebuild the src rpm:
You need to define 'dtag' so it uses the correct buildrequirements for 
centos4:

rpmbuild --define 'dtag el4' --rebuild yoursrcrpm

kind regards,
Dries




More information about the users mailing list