[users] Audacity vs. wxGTK 2.8

Dag Wieers dag at wieers.com
Fri Sep 26 16:53:31 CEST 2008


On Fri, 26 Sep 2008, Niki Kovacs wrote:

> Dag Wieers a écrit :
>
>>  I tried before with audacity 1.3.5. I get:
>>
>>  import/ImportFLAC.cpp: In member function 'virtual void
>>  MyFLACFile::metadata_callback(const FLAC__StreamMetada
>>  ta*)':
>>  import/ImportFLAC.cpp:185: error: 'FLAC__METADATA_TYPE_PICTURE' was not
>>  declared in this scope
>>  make[1]: *** [import/ImportFLAC.o] Error 1
>>  make[1]: Leaving directory `/dar/build/audacity-src-1.3.5-beta/src'
>>  make: *** [audacity] Error 2
>
> I just took a peek at how Fedora 9 does it. According to 
> audacity-nonfree.spec, it's using compat-wxGTK26-devel.
>
> Are there any arguments against using this solution? At least, until someone 
> manages to build Audacity hassle-free against wxGTK2.8?

Why not fix Yum so that it can handle dependency resolution problems. With 
Apt someone who does not have audacity installed would simply update their 
system. Someone with audacity installed can either decide to stay there 
until audacity is fixed, or can decide to have apt uninstall audacity and 
update everything else.

That would make a lot of things easier and avoid having people jump up and 
down and scream when there is a dependency problem, or when they have a 
problem mixing repositories.

With apt the user is in control and can define the policy that matches 
with what they want.

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]


More information about the users mailing list