[users] Any updates on audacity (or alternatives)?

Fabian Arrotin fabian.arrotin at arrfab.net
Tue Apr 28 07:08:55 CEST 2009


Del Merritt wrote:
> MHR wrote:
>> I discovered that I use audacity at home, and wanted to download it
>> here for some, ah, filler-time tasks, but the rpmforge version is
>> broken (gtk library issues).
>>
>> Are these resolved?  It does not seem so (tried it yesterday), so is
>> there an alternative (different program, different repository,
>> anything)?
>>   
> 
> Time has passed.  We have a shiny new point release of CentOS.  But 
> still no Audacity:
> 
>    $ sudo apt-get install audacity
>    Reading Package Lists... Done
>    Building Dependency Tree... Done
>    Some packages could not be installed. This may mean that you have
>    requested an impossible situation or that some of the repositories
>    in use are in an inconsistent state at the moment.
> 
>    Since you only requested a single operation it is extremely likely that
>    the package is simply not installable and a bug report against
>    that package should be filed.
>    The following information may help to resolve the situation:
> 
>    The following packages have unmet dependencies:
>      audacity: Depends: libwx_baseu-2.6.so.0
>                Depends: libwx_baseu-2.6.so.0(WXU_2.6)
>                Depends: libwx_baseu_net-2.6.so.0
>                Depends: libwx_baseu_net-2.6.so.0(WXU_2.6)
>                Depends: libwx_baseu_xml-2.6.so.0
>                Depends: libwx_gtk2u_adv-2.6.so.0
>                Depends: libwx_gtk2u_core-2.6.so.0
>                Depends: libwx_gtk2u_core-2.6.so.0(WXU_2.6)
>                Depends: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2)
>                Depends: libwx_gtk2u_html-2.6.so.0
>                Depends: libwx_gtk2u_html-2.6.so.0(WXU_2.6)
>                Depends: libwx_gtk2u_qa-2.6.so.0
>                Depends: libwx_gtk2u_xrc-2.6.so.0
>    E: Broken packages
> 
> Is this something that can "easily" be fixed at the RPMForge level, or 
> is there still a problem with our beloved upstream that is holding 
> things back?  I apologize for being ignert on this topic; I'm still 
> trying to learn.
> 
> -Del
>

That's still a discussion to have within RPMforge about packages 
building/relying on older wxGTK 2.6 while RPMforge now provides 2.8 ...
One of the ideas is to provide a compat-wxGTK26 package , the same way 
Fedora/Epel is doing to maintain compatibility with older packages still 
needing 2.6 and incompatible with 2.8 ...

-- 
--
Fabian Arrotin
  idea=`grep -i clue /dev/brain`
  test -z "$idea" && echo "sorry, init 6 in progress" || sh ./answer.sh



More information about the users mailing list