[suggest] Possible bug in latest perl-DBD-SQLite package

Kai Schaetzl maillists at conactive.com
Thu Jun 11 13:16:32 CEST 2009


Christoph Maser wrote on Wed, 3 Jun 2009 13:57:01 +0200:

> The perl-DBI package provides
> 
> perl(DBI)
> perl-DBI = 1.52-2.el5
> 
> Note there is no version number on the "perl(DBI)" line. So i guess out
> perl-DBD-SQLite must require perl-DBI => 1.57 instead of perl(DBI) >=
> 1.57.

Oh, it does both:
perl(DBI) >= 1.57
perl-DBI >= 1.57

My point is that as I have priorities-checking on it should try to resolve 
the dependency, should fail (because that required package is excluded by 
priorities) and thus not upgrade both packages. However, it does. Both.
I would consider this a bug in yum or yum-utils. Correct?

Btw, sorry for starting this thread here. Obviously this fits better in 
the users list which I subscribed to now.

Kai

-- 
Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com






More information about the users mailing list