[suggest] subversion 1.6.3 for EL4

Greg Bailey gbailey at lxpro.com
Mon Jun 29 17:09:48 CEST 2009


arnebjarne72 at hotmail.com wrote:

> 2) I can't compile subversion 1.6.3 with the system-included neon. I can 
> however compile it using libserf which is allready available at RPMforge.
> (see http://svn.collab.net/repos/svn/trunk/INSTALL -> * libserf)
> Does anybody know if svn works acceptable with libserf instead of neon?
> 

If neon is unpacked inside the subversion tree, it gets compiled in 
statically, similarly to what's currently done with sqlite.  I like this 
approach because then the user doesn't have to consider multiple 
versions of the same RPM (neon in this case) installed concurrently:  1 
for the OS dependencies and 1 for subversion, and the user doesn't have 
to consider the problems associated with updating a vendor supplied 
library like sqlite or neon to a newer version.  Even though it's 
supported, it just seems easier to maintain (for the user).


> 3) 
> http://lxpro.com/subversion/1.6.3/el4/SPECS/subversion-1.6.3-0.2.el4.rf.spec 
> -> Source4: http://www.xsteve.at/prg/emacs/psvn.el
> Is allready available in the subversion package in 
> ./subversion-1.6.3/contrib/client-side/emacs/psvn.pl so no need for 
> external dependency??
> 

I wondered about this too; I grabbed a more recent copy than what's 
included in subversion 1.6.3 using the URL provided in the .spec file.

-Greg



More information about the users mailing list