[users] Audacious-broken package

Yury V. Zaytsev yury at shurup.com
Thu Jun 4 22:16:57 CEST 2009


Hi!

It's been broken for a few years I guess. I remember I posted about
that, and then somebody else and you're like the third or whatever.

Concerning Audacious, it's virtually impossible to cleanly update it to
the latest version, because it needs newer GTK and the other libs. I
remember that I once managed to compile it from source after patching
the m4 scripts to lower the requirements for GTK, downloading the latest
versions of the libs it needs and statically linking Audacious against
them, but I never managed to make a package out of it, because it was so
much pain.

As far as xmms + flac are concerned, this is a known issue and quite
easy to fix, but nobody cares. I the end, I managed to build flac + flac
plugin, as well as a special patched version of xmms with recode support
myself. You can find the binaries and SRPMs on my web page (i386 only):

http://rpm.zaytsev.net/i386/

Hope that helps,
 
-- 
Sincerely yours,
Yury V. Zaytsev

On Thu, 2009-06-04 at 20:58 +0200, MladenS wrote:
> Audacious package is apparently broken
> 
> I am using CentOS 5.3, and when I try to install it via Pirut I get
> error message
> 
> Error message is:
> 
> Missing Dependency: audacious-plugins >= 1.3.0 is needed by package
> audacious-1.3.2-5.el5.rf.i386 (rpmforge)
> 
> Probably broken dependency-it's complains about missing
> audacious-plugins package
> Could this be fixed in the near future?
> 
> Also, similar problem occurs when I try to install xmms-flac plugin
> 
> Missing Dependency: libFLAC.so.8 is needed by package
> xmms-flac-1.1.4-1.el5.rf.i386 (rpmforge)
> 
> Again,missing flac package and broken dep?
> 
> 
> Thanks in advance... 
> _______________________________________________
> users mailing list
> users at lists.rpmforge.net
> http://lists.rpmforge.net/mailman/listinfo/users




More information about the users mailing list