[users] Can't install geos and gdal

Marwan Gedeon marwan at zaradoustra.com
Thu Jun 25 18:21:07 CEST 2009


It looks like gdal's dependencies require libgeos.so.2 which ships with
an older version of geos, while the geos you're trying to install is the
newest

You could be able to force the older geos installation, then install
gdal, like this:

yum install libgeos.so.2
yum install gdal

I'm no expert on the matter, just an assumption

-----Original Message-----
From: Philip Durbin <philipdurbin at gmail.com>
To: users at lists.rpmforge.net
Subject: [users] Can't install geos and gdal
Date: Thu, 25 Jun 2009 10:43:31 -0400


When I try to install the geos and gdal RPMs from RPMforge on CentOS 5.3 
I get the dependency conflicts below.  Can someone please take a look at 
this?

[root at centos5 ~]# yum install geos gdal
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
  * rpmforge: ftp-stud.fht-esslingen.de
  * base: ftp.lug.udel.edu
  * updates: mirror.anl.gov
  * addons: mirror.atlanticmetro.net
  * extras: ftp.lug.udel.edu
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package geos.x86_64 0:3.1.0-1.el5.rf set to be updated
--> Processing Dependency: libgeos-3.1.0.so()(64bit) for package: geos
---> Package gdal.x86_64 0:1.4.4-1.el5.rf set to be updated
--> Processing Dependency: libnetcdf.so.4()(64bit) for package: gdal
--> Processing Dependency: libodbcinst.so.1()(64bit) for package: gdal
--> Processing Dependency: libgif.so.4()(64bit) for package: gdal
--> Processing Dependency: libgeos.so.2()(64bit) for package: gdal
--> Processing Dependency: libodbc.so.1()(64bit) for package: gdal
--> Running transaction check
---> Package netcdf.x86_64 0:3.6.3-1.el5.rf set to be updated
---> Package gdal.x86_64 0:1.4.4-1.el5.rf set to be updated
--> Processing Dependency: libgeos.so.2()(64bit) for package: gdal
---> Package giflib.x86_64 0:4.1.3-7.1.el5_3.1 set to be updated
---> Package geos-devel.x86_64 0:3.1.0-1.el5.rf set to be updated
---> Package unixODBC.x86_64 0:2.2.11-7.1 set to be updated
--> Finished Dependency Resolution
gdal-1.4.4-1.el5.rf.x86_64 from rpmforge has depsolving problems
   --> Missing Dependency: libgeos.so.2()(64bit) is needed by package 
gdal-1.4.4-1.el5.rf.x86_64 (rpmforge)
Error: Missing Dependency: libgeos.so.2()(64bit) is needed by package 
gdal-1.4.4-1.el5.rf.x86_64 (rpmforge)
[root at centos5 ~]#

Thanks!

Phil
_______________________________________________
users mailing list
users at lists.rpmforge.net
http://lists.rpmforge.net/mailman/listinfo/users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/users/attachments/20090625/8bc2b75f/attachment-0004.html>


More information about the users mailing list