[users] Can't install geos and gdal

Philip Durbin philipdurbin at gmail.com
Thu Jun 25 18:46:47 CEST 2009


> It looks like gdal's dependencies require libgeos.so.2 which ships with 
> an older version of geos, while the geos you're trying to install is the 
> newest
> 
> You could be able to force the older geos installation, then install 
> gdal, like this:
> 
> yum install libgeos.so.2
> yum install gdal

Yes, that is correct; if I run "yum install libgeos.so.2 gdal" an older 
version of geos (2.2.3) is successfully installed.  However, I have an 
application (GeoDjango) that requires geos 3.0.0 or higher.  So it would 
be great if both gdal and the latest version of geos available in 
RPMforge (3.1.0) could be installed side by side.

Can anyone assist with this?  I would be most appreciative.

Phil



More information about the users mailing list