[suggest] Possible bug in latest perl-DBD-SQLite package

Kai Schaetzl maillists at conactive.com
Sat May 30 13:52:52 CEST 2009


David Steinbrunner wrote on Thu, 28 May 2009 12:03:36 -0400:

> Is it possible for you to install the perl module from CPAN rather than
> rpmforge for testing proposes?  I have a feeling the issue is not the
> rpmforge package but rather the newer versions of the software itself.  If
> it is the DBD::SQLite software rather than the packaging, you could then
> submit this as a bug to the maintainers.

I just found the reason for this problem with a simple test script and a 
require.

Newer versions of DBD::SQLite need a DBI version of at least 1.57. The 
rpmforge package *does* include this requirement. However, CentOS includes 
DBI 1.52 and doesn't provide newer versions. As a good administrator I'm 
using yum priorities and thus the software is locked at the CentOS version. 
I would think that yum should not have upgraded perl-DBD-SQLite if it cannot 
fulfill the requirement of perl-DBI >= 1.57. I will follow this up on the 
CentOS list whether it has to be reported as a bug.
So, for anyone else using this module and priorities: you have to either 
stay on version 1.14 or exclude perl-DBI from the base and updates repos 
(which enables rpmforge to upgrade DBI to 1.607).

Kai

-- 
Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com






More information about the users mailing list