[users] Request Perl Data::AMF

Dag Wieers dag at wieers.com
Mon May 18 14:35:52 CEST 2009


On Mon, 18 May 2009, Christoph Maser wrote:

> Am Sonntag, den 17.05.2009, 14:50 +0200 schrieb John Thomas:
>
>> You are correct sorry.  I had to install
>> perl-Class-C3
>> perl-Algorithm-C3
>> perl-Sub-Name
>> perl-Devel-GlobalDestruction
>> then it worked fine.
>>
>> I wonder if those should be additional dependencies.
>
> Dag, shall i add those or should we rather try to find out what is wrong
> with %__perl_requires?
>
> Here ist what is found in my x86_64 mock environment:
>
> DEBUG: Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(VersionedDependencies) <=
> 3.0.3-1
> DEBUG: Requires: perl >= 0:5.008001 perl >= 3:5.8.1
> perl(Data::AMF::Formatter) perl(Data::AMF::Formatter::AMF0)
> perl(Data::AMF::Header) perl(Data::AMF::IO) perl(Data::AMF::Message)
> perl(Data::AMF::Parser) perl(Data::AMF::Parser::AMF0) perl(Moose)
> perl(Scalar::Util) perl(bytes) perl(constant) perl(strict)
> perl(warnings)
>
>
> Not what it should be

Indeed it would be great if we could improve the %__perl_requires script 
upstream, but since it is unlikely to be backported to RHEL3, RHEL4 and 
RHEL5 we should probably add the missing dependencies too.

The script is known to produce both false negatives as well as false 
positives. And it is hard to filter out dependencies if there are false 
positives :-(

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list