[suggest] perl-GnuPG-Interface: broken dependency

Jonas Pasche jpasche at jonaspasche.com
Wed Aug 25 10:26:15 CEST 2010


GnuPG::Interface needs Any::Moose, but the specfile doesn't know of this
dependency, and RPMforge doesn't provide Any::Moose at all:

        # yum install perl-GnuPG-Interface
        [...]
        Installed:
          perl-GnuPG-Interface.noarch
        0:0.42-1.el5.rf                                                                                                                 
        
        Complete!

Now it's installed but non-functional:

        # perl -MGnuPG::Interface
        Can't locate Any/Moose.pm in @INC (@INC
        contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/lib/perl5/vendor_perl/5.8.8/GnuPG/Interface.pm line 15.
        BEGIN failed--compilation aborted
        at /usr/lib/perl5/vendor_perl/5.8.8/GnuPG/Interface.pm line 15.
        Compilation failed in require.
        BEGIN failed--compilation aborted.

Best regards,
Jonas




More information about the users mailing list