[suggest] git-1.7.3-1.rf.src.rpm does not compile on RHEL 5, %filer_from_requires not set

Nico Kadel-Garcia nkadel at gmail.com
Sun Dec 5 04:43:35 CET 2010


I'm taking a look at updating git for some clients, but note that the
git at RPMforge is 1.7.3. That's cool: the latest release is 1.7.3.2,
but that's plenty recent.

But when I recompile the src.rpm, I get the following message:

    error: lin 48: Unknown tag: %filter_from_requires /^perl(packed-refs)*/d

There's clearly some RPM macro undefined there, but it's not in the
RHEL or CentOS 5 basic rpm-build setup. Does anyone understand where
this macro is normally set from, and what its value should be?



More information about the users mailing list