[users] MPlayer package questions

Dag Wieers dag at wieers.com
Tue Dec 7 01:49:13 CET 2010


On Mon, 6 Dec 2010, Greg Bailey wrote:

> 1.  It appears that mplayer-common isn't required by mplayer nor mencoder. 
> Is that intentional?  I took me a couple of minutes to find out what happened 
> to the manpages--which I'd consider essential to deciphering mencoder's many 
> options.  Also things like /etc/mplayer/mplayer.conf are part of 
> mplayer-common, so it seems like it should be a dependency of mplayer and/or 
> mencoder.

Fixed !


> 2.  Once I figure out that I should install mplayer-common, I get the 
> following when using mplayer:
>
> $ mplayer testfile.flv
> The fontconfig option can't be used in a config file.
> Error parsing option fontconfig=yes at line 123

Not sure what I should build differently.


> 3.  After commenting out line 123, when attempting to encode flash video to 
> MPEG4, I get:
>
> $ mencoder -ofps 30000/1001 -af lavcresample=24000 -vf 
> harddup,crop=320:128:0:56,scale=368:208 -of lavf \
>   -oac lavc -ovc lavc -lavcopts 
> aglobal=1:vglobal=1:vcodec=mpeg4:acodec=libfaac \
>    -lavfopts format=psp \
>    -noskip -skiplimit 1 -mc 0 \
>    testfile.flv \
>    -o testfile.mp4
>
> gives MPlayer output, followed by:
>
> ==========================================================================
> Audio LAVC, couldn't find encoder for codec libfaac.
>
> I verified that I have the "faac" RPM installed from RPMForge.

lavc means ffmpeg. So apparently ffmpeg is lacking faac, or mplayer 
refuses to use that one. I have a new rebuild, please test it when it 
comes available. Thanks in advance,

-- 
-- dag wieers, dag at wieers.com, http://dag.wieers.com/
-- dagit linux solutions, info at dagit.net, http://dagit.net/

[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list