[users] the new mplayer for el5

Alfred Ganz alfred-ganz+dag at agci.com
Tue Dec 7 19:14:13 CET 2010


Dag,
	Date: Tue, 7 Dec 2010 17:31:19 +0100 (CET)
	Subject: Re: [users] the new mplayer for el5
	In-Reply-To: <alpine.LRH.2.02.1012071656090.10450 at pikachu.3ti.be>
	
	>> So it looks like there is yet another build option that needs to be
	>> looked at. Unfortunately I don't see anything listed in the summary
	>> field of the spec file to indicate what to do!
	>>
	>> Making progress!
	>
	>Yes, the fontconfig problem still needs to be addressed. And maybe an 
	>smplayer update too ?
	
	Bad news, the current fontconfig support in mplayer requires fontconfig 
	2.4.2. So either we can patch the old fontconfig code back in, or we drop 
	fontconfig support for RHEL5, RHEL4 and RHEL3...
The currently working version (mplayer-1.0-0.43.svn20090711.el5.rf)
does rely on libfontconfig.so.1, building without it would be a major 
downgrade, so I think if mplayer is updated from 1.0-0.43 it needs 
fontconfig support somehow.

RHEL5 provides fontconfig-2.4.1-7.el5, is it potentially possible to 
build the new mplayer with that, ugly I know, but
	http://fontconfig.org/release/ChangeLog-2.4.2
doesn't seem to indicate any major changes against 2.4.1, but mainly
bugfixes (bugs with which current users of mplayer had to live with!). 
Note also that even fontconfig-2.8.0-2.fc14 provides the same library 
(libfontconfig.so.1) as fontconfig-2.4.1-7.el5.

Thanks for working on this! AG

-- 
 ----------------------------------------------------------------------
   Alfred Ganz					alfred-ganz:at:agci.com
   AG Consulting, Inc.				(203) 624-9667
   440 Prospect Street # 11
   New Haven, CT 06511
 ----------------------------------------------------------------------



More information about the users mailing list