[users] perl-Encode error

Khusro Jaleel mailing-lists at kerneljack.com
Mon Dec 13 13:52:35 CET 2010


Hi,

I am trying to install the package 'perl-Encode' from rpmforge on a 
CentOS machine with EPEL also enabled. I am using the priorities plugin 
so Base, EPEL and RPMForge all have different priorities, however I get 
the following error from yum. Any ideas as to how to fix this appreciated

Thanks,


=====================================================================================

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
  * addons: mirror.sov.uk.goscomb.net
  * base: mirror.sov.uk.goscomb.net
  * epel: mirror01.th.ifl.net
  * extras: mirror.ox.ac.uk
  * rpmforge: apt.sw.be
  * updates: mirror.ox.ac.uk
3559 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Encode.x86_64 0:2.39-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================
  Package                           Arch                         
Version                                Repository                      Size
============================================================================================================================================
Installing:
  perl-Encode                       x86_64                       
2.39-1.el5.rf                          rpmforge                       3.0 M

Transaction Summary
============================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 3.0 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
   file /usr/bin/enc2xs from install of perl-Encode-2.39-1.el5.rf.x86_64 
conflicts with file from package perl-5.8.8-32.el5_5.2.x86_64
   file /usr/bin/piconv from install of perl-Encode-2.39-1.el5.rf.x86_64 
conflicts with file from package perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man1/enc2xs.1.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man1/piconv.1.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Alias.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::CJKConstants.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::CN::HZ.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Config.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Encoder.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Encoding.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Guess.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::JP::H2Z.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::JP::JIS7.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::KR::2022_KR.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::MIME::Header.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::PerlIO.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Supported.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/Encode::Unicode::UTF7.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64
   file /usr/share/man/man3/encoding.3pm.gz from install of 
perl-Encode-2.39-1.el5.rf.x86_64 conflicts with file from package 
perl-5.8.8-32.el5_5.2.x86_64

Error Summary
-------------
=====================================================================================




More information about the users mailing list