[users] perl-Encode error

Steve Huff shuff at vecna.org
Mon Dec 13 14:58:10 CET 2010


On Dec 13, 2010, at 8:18 AM, Yury V. Zaytsev wrote:

> On Mon, 2010-12-13 at 12:52 +0000, Khusro Jaleel wrote:
> 
>> Transaction Check Error:
>>   file /usr/bin/enc2xs from install of perl-Encode-2.39-1.el5.rf.x86_64 
>> conflicts with file from package perl-5.8.8-32.el5_5.2.x86_64
>>   file /usr/bin/piconv from install of perl-Encode-2.39-1.el5.rf.x86_64 
> 
> Sounds like more than a man conflict that we can ignore :-(
> 
> File a bug at RH to repackage it as a separate entity?


no, that's not the case; it looks like Encode 2.12 is part of Perl 5.8.8 core, and unfortunately, RH is technically doing the right thing by packaging Encode as part of the perl-5.8.8 RPM.

for our part, it means that perl-Encode needs an rfx tag, since if Khusro forces an install of perl-Encode-2.39, then he's breaking his existing perl package, and he should be aware of it.

Khusro, why are you trying to install a newer Encode than provided?  do you specifically need a version later than 2.12?  why?

-steve

--
If this were played upon a stage now, I could condemn it as an improbable fiction. - Fabian, Twelfth Night, III,v
PGP 8477B706 (A92A 1F7E 6D76 16A0 BFF9  E61D AD54 0251 8477 B706)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 195 bytes
Desc: This is a digitally signed message part
URL: <http://lists.repoforge.org/pipermail/users/attachments/20101213/334392ff/attachment.sig>


More information about the users mailing list