[users] perl-Encode error

Steve Huff shuff at vecna.org
Mon Dec 13 17:12:27 CET 2010


On Dec 13, 2010, at 10:56 AM, Khusro Jaleel wrote:

> So does this mean that in this case, I can only really install the latest version of RT by satisfying all the dependencies using CPAN? There is no other way to do it is there? I don't have the option of using RT 3.6 that EPEL packages because I'm trying to migrate an existing 3.8 system to a CentOS box.


no; it means that if you need newer versions of core Perl modules (which it sounds like you do), then you need to break your perl-5.8.8 package a bit.  the good news is that RPMforge Perl modules install into the vendor_perl branch, so they shouldn't be clobbering the actual .pm files, but you will have to install with rpm --excludedocs to get past the man page conflicts (or with --force if you want the update man pages).  

RT is indeed difficult to install under RHEL, especially recent versions; honestly, if you can, you may want to wait until CentOS 6 is out.

installing from CPAN is a bad idea; don't do that.  

-steve

--
If this were played upon a stage now, I could condemn it as an improbable fiction. - Fabian, Twelfth Night, III,v
PGP 8477B706 (A92A 1F7E 6D76 16A0 BFF9  E61D AD54 0251 8477 B706)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 195 bytes
Desc: This is a digitally signed message part
URL: <http://lists.repoforge.org/pipermail/users/attachments/20101213/d11b2485/attachment.sig>


More information about the users mailing list