[users] perl-Encode error

Scott Robbins scottro at nyc.rr.com
Mon Dec 13 17:54:21 CET 2010


On Mon, Dec 13, 2010 at 03:56:21PM +0000, Khusro Jaleel wrote:
>
>
> I'm trying to install RT and apparently it needs a newer version of  
> Encode, as well as a huge bunch of other Perl things :-(
>
> So does this mean that in this case, I can only really install the  
> latest version of RT by satisfying all the dependencies using CPAN?  
> There is no other way to do it is there? I don't have the option of  
> using RT 3.6 that EPEL packages because I'm trying to migrate an  
> existing 3.8 system to a CentOS box.

RT is a pain to install on CentOS.  I never found a way that avoided
CPAN entirely, but was able to get a great deal of it from rpmforge. 

You can see my page at
http://home.roadrunner.com/~computertaijutsu/rt3.html

I don't know if any of it will help you.

I was using an older version, but that's exactly what I had to do,
migrate it.

Hopefully, you're familiar with migrating it.  The gotcha I ran into was
that I had to change the newer machine's default sendmail 

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl


to 

dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

Another gotcha was that I had to cpoy /opt/rt3/bin/rt3-mailgate to
/etc/smrsh amdn make sure the permissions were 755 owner root, group rt. 

But to answer your original question, I wasn't able to avoid CPAN. 

-- 
Scott Robbins
PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

Angel: So, you're back.
Cordelia: Very good, Mister I-can't-tail-the-suspect-during-the-day-
because-I'll-burst-into-flames Private Eye.



More information about the users mailing list