[users] Problems with Deluge under Centos 5.4 X64

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Fri Feb 12 13:45:36 CET 2010


Yury V. Zaytsev wrote:
> On Thu, 2010-02-11 at 23:20 +0100, Nicolas Thierry-Mieg wrote:
>
>> I can confirm that deluge 0.5.9.0-1.el5.rf x86_64 doesn't show torrents
>> that are added, parts of the GUI are broken (though deluge does seem to
>> download).
>
> Actually this version is so terribly outdated, full of bugs and security
> issues, that I'm even wondering how it works. The problem is the build
> requirements from 1.2.0:
<snip>
> Everything looks more or less reasonable, but I guess we're stuck with
> Python>= 2.5...
>
> What should we do? Wipe this or move to vault and invest into
> Transmission?
>
> http://trac.transmissionbt.com/wiki/Building#CentOS5.4
>

transmission looks nice!

but meeting the deps might be tricky again, since according to that 
webpage it requires:
- intltool 0.40 or newer (C5 has 0.35)
- libcurl 7.16.3 or newer (C5 has 7.15.5)

and an unknown version of pkgconfig (latest is 0.23, C5 has 0.21, from 
the webpage it seems the C5 version won't be enough).

Not sure if you can work around this... maybe using static versions of 
the libs? Not very clean though.



More information about the users mailing list