[users] Problems with Deluge under Centos 5.4 X64

Yury V. Zaytsev yury at shurup.com
Fri Feb 12 15:51:10 CET 2010


On Fri, 2010-02-12 at 13:45 +0100, Nicolas Thierry-Mieg wrote:

> - libcurl 7.16.3 or newer (C5 has 7.15.5)

Been doing static builds for rtorrent for quite a long time...

> - intltool 0.40 or newer (C5 has 0.35)

Shouldn't be too much of an issue.

> and an unknown version of pkgconfig (latest is 0.23, C5 has 0.21, from 
> the webpage it seems the C5 version won't be enough).

This one might be tricky :-(

> Not sure if you can work around this... maybe using static versions of 
> the libs? Not very clean though.

I'm afraid there's no clean way of dealing with this other than

a) Patching the sources to make them buildable with old libs
b) Doing static builds against new libs

Even though b) might not look too clean, a) is just unpractical (read
impossible). Which leaves us with static builds which one can satisfy
(Python 2.6 is clearly a no-go)...
 
-- 
Sincerely yours,
Yury V. Zaytsev




More information about the users mailing list