[suggest] broken dependencies for some perl modules on RHEL4

Dave B botsch at cnf.cornell.edu
Tue Jun 8 15:36:07 CEST 2010


This is definitely broken on RHEL4 w.r.t. up2date .

On everyone one of our machines...


up2date -l

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching rpm headers...
########################################

Name                                    Version              Rel
Arch
----------------------------------------------------------------------------------------
perl                                    5.8.5               53.el4
i386  
perl-suidperl                           5.8.5               53.el4
i386  

up2date -u perl

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching rpm headers...
########################################

Name                                    Version              Rel
A
rch
--------------------------------------------------------------------------------
--------
perl                                    5.8.5
53.el4              
i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
perl-DBD-Pg-2.17.1-1.el4.rf              requires perl >= 5.006001 




--

********************************
David William Botsch
Programmer/Analyst
CNF Computing
botsch at cnf.cornell.edu
********************************





More information about the users mailing list