[suggest] dependency problem for perl-DBD-SQLite

Mark D. Nagel mnagel at willingminds.com
Sun Nov 28 05:20:16 CET 2010


It appears that the dependency on the minimum perl-DBI version was 
removed from perl-DBD-SQLite after 1.25-2 in the repository.  The latest 
versions install, but yields at runtime:

install_driver(SQLite) failed: DBI version 1.57 required--this is only 
version 1.52 at 
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/DBD/SQLite.pm 
line 5

The 1.25-2 RPM properly fails to install (due to lack of the rfx repo in 
scope):

perl-DBD-SQLite-1.25-2.el5.rf.i386 from rpmforge has depsolving problems
   --> Missing Dependency: perl-DBI >= 1.57 is needed by package 
perl-DBD-SQLite-1.25-2.el5.rf.i386 (rpmforge)
Error: Missing Dependency: perl-DBI >= 1.57 is needed by package 
perl-DBD-SQLite-1.25-2.el5.rf.i386 (rpmforge)

Regards,
Mark




More information about the users mailing list