[users] perl-AnyEvent-5.240-1.el5.rf.noarch depsolving problems

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Mon Nov 15 14:53:16 CET 2010


Jack Bailey wrote:
>    Hello,
>
> I'm getting an error on perl-AnyEvent doing a fresh install of CentOS
> 5.5 i386
>
> # yum update
> [snip]
> perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving problems
> --> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package
> perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
> package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)


perl-AnyEvent needs perl(Net::SSLeay) >= 1.33, but centos provides 1.30.
rpmforge provides 1.36, but you have to allow it to install over the 
base C5 package.
something like yum --disable=* --enable=rpmforge blabla, sorry I don't 
use yum and don't know it's syntax.

HTH



More information about the users mailing list