[users] request: update of libmatroska

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Mon Nov 15 17:39:52 CET 2010


Hello,

recently I have been encountering mkv files that cannot be read with 
xine or mplayer from rpmforge.
I noticed that libmatroska (and libebml on which it depends) are at 
version 1.0.0 on http://www.matroska.org/downloads/linux.html . 
Hopefully these newer versions might allow to view the problematic mkv 
files.

I could not try to rebuild these versions myself, because installing the 
rf srpm fails although my file does not seem corrupted:

[nthierry at tryo Build]$ rpm -K libebml-0.7.8-1.rf.src.rpm
libebml-0.7.8-1.rf.src.rpm: (sha1) dsa sha1 md5 gpg OK
[nthierry at tryo Build]$ rpm -ivh libebml-0.7.8-1.rf.src.rpm
    1:libebml    warning: user dag does not exist - using root
warning: group dag does not exist - using root
########################################### [100%]
error: unpacking of archive failed on file 
/home/nthierry/rpms/Build/SOURCES/libebml-0.7.8.tar.bz2;4ce160a0: cpio: 
MD5 sum mismatch

[as a side note: what's the problem here, am I doing something wrong?]

However I looked at some announcements and changelogs and it seems they 
should build easily.

Anyone have the skills and time to try to build the newer libebml and 
libmatroska?

Thanks!

Regards,
Nicolas



More information about the users mailing list