[users] Lingering RHEL4 dependency problems

Bart Schaefer barton.schaefer at gmail.com
Sun Nov 21 20:53:25 CET 2010


I've had the following errors when running "yum update" on my CentOS 4
box for several months now.  I thought perhaps they'd go away after
the recently-announced rpmforge repository split into
extras/testing/etc. but that didn't change anything.  (Does the split
apply to all RHEL versions or only RHEL5 & 6?)

perl-AnyEvent.noarch                     5.240-1.el4.rf         rpmforge
perl-Module-Install.noarch               0.92-1.el4.rf          rpmforge
rar.i386                                 3.8.0-1.el4.rf         rpmforge

Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package rar
Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package
perl-Module-Install
Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package perl-AnyEvent

I don't think there's any way to resolve the GLIBC_2.4 dependency on
RHEL4 so either rar needs to be rebuilt or removed from the
repository?  The perl issues are probably related to protectbase.



More information about the users mailing list