[users] Lingering RHEL4 dependency problems

Dag Wieers dag at wieers.com
Sun Nov 21 23:00:10 CET 2010


On Sun, 21 Nov 2010, Bart Schaefer wrote:

> I've had the following errors when running "yum update" on my CentOS 4
> box for several months now.  I thought perhaps they'd go away after
> the recently-announced rpmforge repository split into
> extras/testing/etc. but that didn't change anything.  (Does the split
> apply to all RHEL versions or only RHEL5 & 6?)

The split applies to all repositories, but we still need to move quite 
some packages from rpmforge to rpmforge-testing as some dependencies are 
not met.

The below problems ofcourse are different, they should never have been 
introduced.

> perl-AnyEvent.noarch                     5.240-1.el4.rf         rpmforge
> perl-Module-Install.noarch               0.92-1.el4.rf          rpmforge
> rar.i386                                 3.8.0-1.el4.rf         rpmforge
>
> Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package rar
> Missing Dependency: perl(Archive::Tar) >= 1.44 is needed by package
> perl-Module-Install
> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package perl-AnyEvent

> I don't think there's any way to resolve the GLIBC_2.4 dependency on
> RHEL4 so either rar needs to be rebuilt or removed from the
> repository?  The perl issues are probably related to protectbase.

I have set up repoclosure to make sure we tackle each of them, but there's 
a lot to resolve and I was planning to first focus on RHEL6 and then 
RHEL5, RHEL4, RHEL3 and RHEL2 :-)

It won't happen overnight, this is something that will take weeks :-/

-- 
-- dag wieers, dag at wieers.com, http://dag.wieers.com/
-- dagit linux solutions, info at dagit.net, http://dagit.net/

[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list