[users] perl-DBD-SQLite.rf breaks with perl-DBI from Centos 5.5 Base

christian jeitler chris at linuxwochen.at
Tue Nov 23 18:15:36 CET 2010


Hello rpmforge,


  perl-DBD-SQLite from RPMforge breaks when using perl-DBI from CentOS 
Base (which was former in the RPMforge Repository). To fix this i had to 
Install perl-DBI from the RPMforge Extras Repository.

The problem is, that no dependency messages appear. And everything looks 
fine until your application suddenly breaks.

Further, i can't find any documentation how to use RPMforge Extras and 
the idea behind on the RPMforge website.

Should i write one?


On a fresh installed CentOS 5.5 with enabled RPMforge this occurs:

[root at centos ~]# perl -e 'require DBD::SQLite'
DBI version 1.57 required--this is only version 1.52 at 
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/DBD/SQLite.pm 
line 5.

[rpmforge]
name = Red Hat Enterprise $releasever - RPMforge.net - dag
#baseurl = http://apt.sw.be/redhat/el5/en/$basearch/dag
mirrorlist = http://apt.sw.be/redhat/el5/en/mirrors-rpmforge

[root at centos ~]# yum info perl-DBI
Name       : perl-DBI
Arch       : i386
Version    : 1.52
Release    : 2.el5

[root at centos ~]# yum info perl-DBD-SQLite
Name       : perl-DBD-SQLite
Arch       : i386
Version    : 1.29
Release    : 1.el5.rf

cheers

Christian Jeitler

-- 
+43 - 699 - 81729005
chris at linuxwochen.at

Verein Linuxwochen
Museumsplatz 1
1070 Wien
ZVR: 320875837



More information about the users mailing list