[users] trac 0.12 for el6

Yury V. Zaytsev yury at shurup.com
Sun Aug 14 23:03:14 CEST 2011


Hi!

Thank you for the information...

On Fri, 2011-08-12 at 08:49 -0700, Paul Heinlein wrote: 
> 
> 1. Building python-genshi from the published repoforge SRPM:
>     python-genshi-0.6-1.rf.src.rpm. It seems to build cleanly
>     on CentOS 6.

I've pushed an update, will take awhile, but once it's built, it will
become available in RFX.

> 2. Changing some dependencies in the trac.spec file included with
>     the trac-0.12-2.rf.src.rpm:
> 
>     - BuildRequires and Requires from python >= 2.4 to
>       python >= 2.6

Why so?

> - BuildRequires and Requires from python-sqlite2 to
>       python-sqlite >= 2.3

Yes, here we have a problem.

On RHEL6+ we need to require python-sqlite, which is actually provided
by the python-2.6 package, on RHEL5- we need to provide our own
python-sqlite2.

The latter I have just committed and it's in the rebuild queue, but this
means that the Trac package needs some conditional requires.

I will file a bug, but I don't have time to spare on that as I am not
managing an Trac installations at the moment, although I possibly will. 

Also, Trac itself should be updated to the latest version.

> - Requires from mod_python to mod_wsgi

Yes, this is another problem. Of course, mod_wsgi is the clear way to
go, but then we probably should provide a backport for at least RHEL5
and...

> I haven't taken the time to write a decent conf.d/trac.conf file that 
> works with mod_wsgi instead of mod_python, so I can't give you a 
> decent patch for the spec file.

... this is the second big issue which I certainly won't have time to
take care of. *Please* do provide a prototype whenever you'll come up
with it.

> Please accept my apologies. I still thought the information might be
> useful to someone.

Apologies accepted ;-)

Thanks for the heads up,

-- 
Sincerely yours,
Yury V. Zaytsev





More information about the users mailing list