[users] Clamav-milter

Ned Slider ned at unixmail.co.uk
Sat Dec 3 18:30:59 CET 2011


On 02/12/11 23:58, Nicolaas Hyatt wrote:
> The clamav-milter package currently lists sendmail as a requirment.
> However, sendmail is no longer the default MTA for RHEL 6. Is it
> possible to remove this requirement? The default MTA for RHEL 6,
> postfix, has the ability to use sendmail milters, and it would be so
> nice to be able to take advantage of the clamav-milter with postfix with
> out having to also install sendmail.
>
> Now, if sendmail is required for other reasons other than past convince,
> please feel to ignore my request. Thanks in advance!


The way this is normally handled is by requiring a virtual provides that 
is present in both packages (postfix and sendmail).

The generic virtual provides usually used is either MTA or smtpdaemon, 
which are both provided by postfix and sendmail (and exim on RHEL5).

I'll submit a fix here:

https://github.com/repoforge/rpms

but github is currently a little out of sync - clamav-0.97.2-1 is 
currently showing as the latest version although I have 
clamav-0.97.3-1.el5.rf installed here as the latest. Perhaps Dag can fix 
that for us :-)




More information about the users mailing list