[users] netcdf in rpmforge vs epel

Orion Poplawski orion at cora.nwra.com
Fri Jun 3 17:45:52 CEST 2011


netcdf-4.1.2 appears to have shown up in rpmforge for EL6.  This causes some 
problems with my EPEL enabled machine:

Error: Package: GMT-4.5.6-1.el6.x86_64 (@epel-6-x86_64)
            Requires: libnetcdf.so.6()(64bit)
            Removing: netcdf-4.1.1-3.el6.2.x86_64 (@epel-6-x86_64)
                libnetcdf.so.6()(64bit)
            Updated By: netcdf-4.1.2-1.el6.rf.x86_64 (rpmforge)
                Not found
Error: Package: gdl-0.9.1-1.el6.x86_64 (@epel-6-x86_64)
            Requires: libnetcdf.so.6()(64bit)
            Removing: netcdf-4.1.1-3.el6.2.x86_64 (@epel-6-x86_64)
                libnetcdf.so.6()(64bit)
            Updated By: netcdf-4.1.2-1.el6.rf.x86_64 (rpmforge)
                Not found
Error: Package: grads-2.0-0.a9.1.el6.x86_64 (@epel-6-x86_64)
            Requires: libnetcdf.so.6()(64bit)
            Removing: netcdf-4.1.1-3.el6.2.x86_64 (@epel-6-x86_64)
                libnetcdf.so.6()(64bit)
            Updated By: netcdf-4.1.2-1.el6.rf.x86_64 (rpmforge)
                Not found
Error: Package: wgrib2-1.9.1-4.el6.x86_64 (@epel-6-x86_64)
            Requires: libnetcdf.so.6()(64bit)
            Removing: netcdf-4.1.1-3.el6.2.x86_64 (@epel-6-x86_64)
                libnetcdf.so.6()(64bit)
            Updated By: netcdf-4.1.2-1.el6.rf.x86_64 (rpmforge)
                Not found
Error: Package: ncl-5.2.1-6.el6.x86_64 (@epel-6-x86_64)
            Requires: libnetcdf.so.6()(64bit)
            Removing: netcdf-4.1.1-3.el6.2.x86_64 (@epel-6-x86_64)
                libnetcdf.so.6()(64bit)
            Updated By: netcdf-4.1.2-1.el6.rf.x86_64 (rpmforge)
                Not found
Error: Package: gdal-1.7.2-1.el6.x86_64 (@epel-6-x86_64)
            Requires: libnetcdf.so.6()(64bit)
            Removing: netcdf-4.1.1-3.el6.2.x86_64 (@epel-6-x86_64)
                libnetcdf.so.6()(64bit)
            Updated By: netcdf-4.1.2-1.el6.rf.x86_64 (rpmforge)
                Not found

Shall we just chalk it up to EPEL/RPMForge incompatibility?  Do we really need 
it in RPMForge?  At the moment there aren't any other RPMForge packages that 
require it.  BTW - I'm the netcdf (and GMT,gdl,wgrib2,ncl) maintainer in EPEL.

It is unfortunate that they bumped to soversion in 4.1.2 - there really was no 
need to.  Water under the bridge now though I think.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  orion at cora.nwra.com
Boulder, CO 80301              http://www.cora.nwra.com



More information about the users mailing list