[users] Request and a bug: gksu

Yury V. Zaytsev yury at shurup.com
Mon Jun 6 22:18:54 CEST 2011


On Mon, 2011-06-06 at 11:47 -0700, Todd And Margo Chester wrote:

> Why?  What am I missing?  Older code is harmful, why?  SL6
> is all out-of-date anyway.  What harm does one more out-of-date
> app cause amongst the thousands of other out-of-date apps?
> No dependencies were added.  I do not get it.  Please educate me.

I consider this too basic Linux knowledge, to be elaborated on this
list. The keywords are "linking", "ABI / API compatibility", "rpm
versions" etc. Otherwise see Jim's comprehensive reply.

You *might* get away with mixing packages *sometimes*, but at other
times, it can cause anything in between software malfunctioning and
catastrophic data loss. And very certainly, it is a bad idea for
anything security related, such as gksu.

-- 
Sincerely yours,
Yury V. Zaytsev





More information about the users mailing list