[users] vlc dependency conflict with EPEL libmodplug

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Tue Jun 21 11:48:50 CEST 2011


Steven L. Seed wrote:
> We use packages both from rpmforge and epel. The current version of the
> vlc package fails to install when including epel because there is a
> newer version of libmodplug in epel and vlc is dependent on the older
> version.
>
>
> Here are the versions:
>
> rf: libmodplug-0.8.7-1.el6.rf.x86_64.rpm, vlc-1.1.9-1.el6.rf.x86_64.rpm
> epel: libmodplug-0.8.8.1-2.el6.x86_64.rpm
>
> I've rebuilt vlc on my own using the newer libmodplug from epel and it
> all seems to work fine. My question:
>
> Can you possibly update the libmodplug package in your repo to reflect
> the one in epel, or even remove yours in favor of theirs?

removing the rf libmodplug is certainly not an option, centos/rhel + rf 
must be closed (ie any rf package must be installable using only deps in 
centos/rhel and rf).
Try asking epel to remove libmodplug because it is in rf (and was in rf 
before epel even existed), you'll get the same answer.

The working solution is for you to be very careful when mixing third 
party repos, use priorities, choose one main third party repo and only 
enable other repos on a case by case basis.
Here if you want the rf vlc, use the rf version of libmodplug, ie 
disable epel and enable rf when installing vlc.



More information about the users mailing list