[users] RPMforge error while executing YUM Update

Avinash Rao avinash.rao at vvki.net
Tue Jun 21 16:37:03 CEST 2011


On Tue, Jun 21, 2011 at 6:17 PM, Nicolas Thierry-Mieg <
Nicolas.Thierry-Mieg at imag.fr> wrote:

> > On Tue, Jun 21, 2011 at 2:47 PM, Nicolas Thierry-Mieg
> > <Nicolas.Thierry-Mieg at imag.fr <mailto:Nicolas.Thierry-Mieg at imag.fr>>
> wrote:
> >
> >     Avinash Rao wrote:
> >      >
> >      >
> >      > On Mon, Jun 20, 2011 at 9:36 PM, ml at smtp.fakessh.eu
> >     <mailto:ml at smtp.fakessh.eu>
> >      > <mailto:ml at smtp.fakessh.eu <mailto:ml at smtp.fakessh.eu>>
> >     <ml at smtp.fakessh.eu <mailto:ml at smtp.fakessh.eu>
> >      > <mailto:ml at smtp.fakessh.eu <mailto:ml at smtp.fakessh.eu>>> wrote:
> >      >
> >      >     Le lundi 20 juin 2011 17:04, Avinash Rao a écrit :
> >      > > Hi,
> >      > >
> >      > > I am using OS: Centos 5.6 64-bit edition on a 2GB Linode.
> >      > > Below are the last few lines of yum update command executed as
> >     root.
> >      > >
> >      > > I have another server with the same configuration and the update
> >      >     happens
> >      > > without any problems.
> >      > >
> >      > > Any help is appreciated.
> >      > > Avinash
> >      > >
> >      > > --> Finished Dependency Resolution
> >      > > perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving
> >      >     problems
> >      > > --> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
> >      >     package
> >      > > perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> >      > > Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed
> by
> >      >     package
> >      > > perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> >      > > You could try using --skip-broken to work around the problem
> >      > > You could try running: package-cleanup --problems
> >      > > package-cleanup --dupes
> >      > > rpm -Va --nofiles --nodigest
> >      > > The program package-cleanup is found in the yum-utils package.
> >      >
> >      >     is typically a problem of priority.
> >      >
> >      >     a yum update what is going well --disablerepo=*
> >     --enablerepo=rpmforge
> >      >
> >      >
> >      >       should solve the problem
> >      >
> >      >
> >      > Hi,
> >      >
> >      >
> >      > I did a yum update  --disablerepo=* --enablerepo=rpmforge
> >      > But the same problem persists.
> >      >
> >      > I have also tried yum clean all, tried reinstalling the perl
> packages
> >      > and nothing worked.
> >
> >     didn't you read my reply?
> >     it's in rpmforge-extras, not rpmforge.
> >     you need to be up to date on rpmforge-release beforehand to "know
> about"
> >     rpmforge-extras.
> >
>
> Avinash Rao wrote:
>  >   Hi Nicolas,
>  >
>  > First, I did  yum update rpmforge-release and there were no updates.
>  > And, yum update  --disablerepo=* --enablerepo=rpmforge-extras but the
>  > problem still exists.
>  > Am I doing it correctly, what you are asking me to do?
>  > I am sorry am not an expert on this.
>
> please don't top-post.
>
> rfx packages can depend on rf (and on centos/rhel).
> Try:
> yum install  --disablerepo=* --enablerepo=rpmforge-extras,rpmforge
> perl-AnyEvent
>


Hi Nicolas,

yum install  --disablerepo=* --enablerepo=rpmforge-extras,rpmforge
perl-AnyEvent  worked..

After this, i was able to update the system.
Thank you very much for your inputs.
Regards,
Avinash







> _______________________________________________
> users mailing list
> users at lists.repoforge.org
> http://lists.repoforge.org/mailman/listinfo/users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/users/attachments/20110621/3b5163c3/attachment-0002.html>


More information about the users mailing list