[suggest] perl-WWW-Mechanize dependency problem on el4

Mark D. Nagel mnagel at willingminds.com
Fri Mar 18 17:15:25 CET 2011


After installing the latest perl-WWW-Mechanize-1.66 on el4, the module
fails as follows:

LWP::UserAgent version 5.827 required--this is only version 2.031 at
/usr/lib/perl5/vendor_perl/5.8.5/WWW/Mechanize.pm line 132.

Notwithstanding the invalid version interpretation from the module as
shown, the standard version of perl-libwww-perl on el4 is
perl-libwww-perl-5.79-5 and the centosplus version is
perl-libwww-perl-5.805-1.1.1.  I'd suggest either backing the published
version of perl-WWW-Mechanize down to one compatible with 5.79 or 5.805,
or releasing a newer perl-libwww-perl into rfx.  The dependency should
also be set in the RPM I think to avoid accidental installation.

Regards,
Mark

-- 
Mark D. Nagel, CCIE #3177 <mnagel at willingminds.com>
Principal Consultant, Willing Minds LLC (http://www.willingminds.com)
cell: 949-279-5817, desk: 714-495-4001, fax: 949-623-9854

*** Please send support requests to support at willingminds.com! *** 




More information about the users mailing list