[suggest] Re: [sugess] cacti-0.8.7g with patchs and PIAv2.9

Fernando Herrero Peletero alpharpm at gmail.com
Wed Mar 30 20:48:52 CEST 2011


My "diff" file was created using the following method:
1. Seven official patches applied to the original source
2. I applied the diff file of the PIA 2.9
3. I added to cacti.sql the code of pa.sql
4. I ran diff the results obtained with respect to the original source.

Why did this instead of applying the patches from the spec?
1. Pa.sql file was not created.
2. If the package included the IPA, why have the pa.sql? It was more 
logical join the cacti.sql and pa.sql.
3. # rpmbuild --rebuild cacti-0.8.7g-3.rf.src.rpm
     Instalando cacti-0.8.7g-3.rf.src.rpm
     advertencia:usuario dag no existe - utilizando root
     advertencia:grupo dag no existe - utilizando root
     error: falló el desempaquetado de archivos  en 
archivo/usr/src/redhat/SOURCES/cacti-0.8.7g.tar.gz;4d937a4e: cpio: El 
MD5 sum no coincide
     error: cacti-0.8.7g-3.rf.src.rpm no puede ser instalado



Yury V. Zaytsev escribió:
> On Wed, 2011-03-30 at 15:29 +0200, Fernando Herrero Peletero wrote:
>> My spec apply these patches:
> ...
>
> Hi Dag!
>
> Could you please rebuild cacti for el5- ? Latest version is only built
> for el6, which is apparently the reason for confusion.
>
>>   I just updated the patches applied, I added some new and also I added
>>   the PIA. The Plugin Architecture is not a plugin, but is required for
>>   install plugins.
> I see. It is very annoying that they don't provide diff&  sql online
> bundling it into one huge package with changed files instead. I will
> look into adding it. Some day :-)
>
> I asked on the IRC, but it appears there are no admins in there...
>




More information about the users mailing list