[suggest] icinga 1.4.0 - provides nagios line

Jose Pedro Oliveira jpo at di.uminho.pt
Sun May 15 23:33:48 CEST 2011


On 2011-05-11 07:24, Michael Friedrich wrote:
> Hi,
> 
> just because of getting the release into rpmforge, I've updated the spec
> file shipping within the tarball to match 1.4.0 as version and latest
> changes. it runs smoothly and creates all required pkg.

Michael,

What's the reason for versioning the virtual nagios provides?

Specfile diff from 1.3.1-1 to 1.4.0-2:
-----------
@@ -28,7 +28,7 @@
 BuildRequires: libjpeg-devel
 BuildRequires: libdbi-devel
 BuildRequires: perl(ExtUtils::Embed)
-Provides: nagios
+Provides: nagios = %{version}
·
 %description
 Icinga is an application, system and network monitoring application.
------------

This seems to be rather wrong/misleading as the current upstream nagios
version is 3.2.3 and the above line creates a nagios 1.4.0 provides:

----------
$ rpm -qp --provides icinga-1.4.0-2.el6.x86_64.rpm | grep nagios
nagios = 1.4.0
----------

Shouldn't it be better to revert this line change?
(i.e., ship an unversioned nagios provides, like in the
icinga 1.3.1 specfile)

Regards,
jpo
-- 
José Pedro Oliveira
* mailto:jpo at di.uminho.pt *



More information about the users mailing list