[users] Subversion 1.6.17 srpm tools, for RHEL 4/5/6 compatible 1.6.x releases

Denis Fateyev denis at fateyev.com
Tue Apr 24 22:13:30 CEST 2012


Hello Nico,

I have seen the specs, really amazing work! But there are some questions:

1) Wouldn't it be better to synchronize `psvn.el` and `subversion.conf`
files between the releases? I certainly could do it, but I know you can do
it more accurately.

2) I doubt that the trick with `gnome-keyring.h` in `BuildRequires` is
really needed. The package called the same in both releases, actually
`gnome-keyring-devel`.


As for the build procedure itself, seems packages are built nicely in RHEL5
and RHEL6 under mock, but I have experienced some unexpected multilib
issues with static build (pure and simple `rpmbuild`.) Since mock works
fine it cannot be considered as a problem unless DAR uses the same technic
(I haven't checked it though.)

---
wbr, Denis.


On Sat, Apr 14, 2012 at 5:30 PM, Nico Kadel-Garcia <nkadel at gmail.com> wrote:

> Subversion 1.6.18 just came out a few days ago. It has a few minor fixes,
> but I had some RHEL 4 compilation issues with my github version of 1.6.17,
> so I've updated both and renamed the repo. I'ts now:
>
> https://github.com/nkadel/subversion-1.6.18-srpm
>
> Please use the updated repo for the next Repoforge Subversion release, it
> does a much better job getting the perl widgets into the RHEL 4 version.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/users/attachments/20120425/d6627d8a/attachment-0002.html>


More information about the users mailing list