[users] Broken package: Package nagios-plugins-dhcp / nagios-plugins-setuid

Nico Schottelius nico-rpmforge.net at schottelius.org
Mon Jan 23 11:20:08 CET 2012


Hello,

trying to install nagios-plugins-all results in the following error:

/usr/bin/yum -d 0 -e 0 -y install nagios-plugins-all:

--------------------------------------------------------------------------------
Package nagios-plugins-dhcp is obsoleted by nagios-plugins-setuid, but obsoleting package does not provide for requirements
Package nagios-plugins-icmp is obsoleted by nagios-plugins-setuid, but obsoleting package does not provide for requirements
Package nagios-plugins-dhcp is obsoleted by nagios-plugins-setuid, but obsoleting package does not provide for requirements
Package nagios-plugins-icmp is obsoleted by nagios-plugins-setuid, but obsoleting package does not provide for requirements
Package nagios-plugins-dhcp is obsoleted by nagios-plugins-setuid, but obsoleting package does not provide for requirements
Error: Package: nagios-plugins-all-1.4.15-2.el6.x86_64 (EPEL)
           Requires: nagios-plugins-dhcp
           Available: nagios-plugins-dhcp-1.4.15-2.el6.x86_64 (EPEL)
               nagios-plugins-dhcp = 1.4.15-2.el6
Error: Package: nagios-plugins-all-1.4.15-2.el6.x86_64 (EPEL)
           Requires: nagios-plugins-icmp
           Available: nagios-plugins-icmp-1.4.15-2.el6.x86_64 (EPEL)
               nagios-plugins-icmp = 1.4.15-2.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

--------------------------------------------------------------------------------

I'm using CentOS 6 with those packages coming from repoforge.

Is this the right list to report / what is the usual approach to fix this
situation?

Cheers,

Nico

-- 
PGP key: 7ED9 F7D3 6B10 81D7 0EC5  5C09 D7DC C8E4 3187 7DF0



More information about the users mailing list