[users] bug?! allegro-4.2.1-1.el6.rf.x86_64

Dag Wieers dag at wieers.com
Wed Jan 25 14:47:00 CET 2012


On Tue, 3 Jan 2012, Chris Syntichakis wrote:

> This is a bit strange....
>
> I assume that this package contains the : liballeg.so.4.2
> BUT after the installation there is no such file installed! (normally
> should be installed under /usr/lib64)

Your assumption is correct:

[root at lisse rpms]# rpm -qplv /dar/packages/allegro/allegro-4.2.1-1.el6.rf.x86_64.rpm  | grep liballeg
lrwxrwxrwx    1 root    root               17 Nov 12  2010 /usr/lib64/liballeg.so.4.2 -> liballeg-4.2.1.so

It seems only the symlink is there, but not the actual library, which is 
part of the allegro-devel. This is a very unusual setup, normally the 
symlink is made the other way around and .so symlinks belong in the -devel 
package.

I will fix it, but this is an upstream problem IMO.

PS Could you please open an issue at http://github.com/repoforge next time ?

Thanks !
-- 
-- dag wieers, dag at wieers.com, http://dag.wieers.com/
-- dagit linux solutions, info at dagit.net, http://dagit.net/

[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list