[users] Yum Update Error perl-IO-Compress Conflict

Ned Slider ned at unixmail.co.uk
Tue Mar 6 16:16:44 CET 2012


On 05/03/12 21:55, Hotmail wrote:
> When I currently run the yum update command I am getting the following error after it marks the packages it needs to update:
>
> Transaction Check Error:
> file /usr/share/man/man3/Compress::Zlib.3pm.gz from install of perl-IO-Compress-2.030-1.noarch conflicts with file from package perl-Compress-Zlib-1.42-1.fc6.i386
>
> perl-IO-Compress is a package from the rpmforge repo and appears to be trying to overwrite files belonging to perl-Compress-Zlib which comes from the CentOS base repo. It should not do this.


perl-IO-Compress shouldn't conflict with perl-Compress-Zlib as 
perl-IO-Compress should Obsolete it:

rpm -q --obsoletes perl-IO-Compress
perl-Compress-Zlib
perl-IO-Compress-Bzip2
perl-IO-Compress-Base
perl-IO-Compress-Zlib


Besides, perl-IO-Compress is in the extras repo as it updates base 
components (or in this case replaces base components).

Also, something isn't quite right as I don't even see a 
perl-IO-Compress-2.030-1.noarch package available; that package doesn't 
look like it's from rpmforge:

Installed Packages
perl-IO-Compress.noarch             2.037-1.el5.rfx              installed
Available Packages
perl-IO-Compress.noarch             2.030-2.el5.rfx 
rpmforge-extras
perl-IO-Compress.noarch             2.033-1.el5.rfx 
rpmforge-extras
perl-IO-Compress.noarch             2.034-1.el5.rfx 
rpmforge-extras
perl-IO-Compress.noarch             2.035-1.el5.rfx 
rpmforge-extras
perl-IO-Compress.noarch             2.036-1.el5.rfx 
rpmforge-extras
perl-IO-Compress.noarch             2.037-1.el5.rfx 
rpmforge-extras


If you are having problems updating, first uninstall perl-Compress-Zlib 
before installing perl-IO-Compress.




More information about the users mailing list