[users] perl-IO-Compress conflict with rpmforge extras enabled

Fred Kienker fkienker at at4b.com
Fri May 4 15:18:21 CEST 2012


The old perl-IO-Compress conflict error has reappeared. I’m installing
CentOS 6.2 Base and have the rpmforge-extras enabled. When I run “yum
update” I get:

 

* base: mirror.teklinks.com

* extras: mirrors.bluehost.com

* rpmforge: apt.sw.be

* rpmforge-extras: apt.sw.be

* updates: mirror.fdcservers.net

Setting up Update Process

Resolving Dependencies

--> Running transaction check

---> Package perl-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
obsoleted

--> Processing Dependency: perl-Compress-Zlib for package:
perl-core-5.10.1-119.el6_1.1.x86_64

---> Package perl-IO-Compress.noarch 0:2.037-1.el6.rfx will be
obsoleting

--> Processing Dependency: perl(Compress::Raw::Bzip2) = 2.037 for
package: perl-IO-Compress-2.037-1.el6.rfx.noarch

--> Processing Dependency: perl(Compress::Raw::Zlib) = 2.037 for
package: perl-IO-Compress-2.037-1.el6.rfx.noarch

---> Package perl-IO-Compress-Base.x86_64 0:2.020-119.el6_1.1 will be
obsoleted

--> Processing Dependency: perl-IO-Compress-Base for package:
perl-core-5.10.1-119.el6_1.1.x86_64

---> Package perl-IO-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
obsoleted

--> Processing Dependency: perl-IO-Compress-Zlib for package:
perl-core-5.10.1-119.el6_1.1.x86_64

--> Running transaction check

---> Package perl-Compress-Raw-Bzip2.x86_64 0:2.037-1.el6.rf will be
installed

---> Package perl-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
obsoleted

--> Processing Dependency: perl-Compress-Zlib for package:
perl-core-5.10.1-119.el6_1.1.x86_64

---> Package perl-IO-Compress.noarch 0:2.037-1.el6.rfx will be
obsoleting

--> Processing Dependency: perl(Compress::Raw::Zlib) = 2.037 for
package: perl-IO-Compress-2.037-1.el6.rfx.noarch

---> Package perl-IO-Compress-Base.x86_64 0:2.020-119.el6_1.1 will be
obsoleted

--> Processing Dependency: perl-IO-Compress-Base for package:
perl-core-5.10.1-119.el6_1.1.x86_64

---> Package perl-IO-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
obsoleted

--> Processing Dependency: perl-IO-Compress-Zlib for package:
perl-core-5.10.1-119.el6_1.1.x86_64

--> Finished Dependency Resolution

Error: Package: perl-core-5.10.1-119.el6_1.1.x86_64
(@anaconda-CentOS-201112091719.x86_64/6.2)

           Requires: perl-IO-Compress-Zlib

           Removing: perl-IO-Compress-Zlib-2.020-119.el6_1.1.x86_64
(@anaconda-CentOS-201112091719.x86_64/6.2)

               perl-IO-Compress-Zlib = 2.020-119.el6_1.1

           Obsoleted By: perl-IO-Compress-2.037-1.el6.rfx.noarch
(rpmforge-extras)

               Not found

Error: Package: perl-core-5.10.1-119.el6_1.1.x86_64
(@anaconda-CentOS-201112091719.x86_64/6.2)

           Requires: perl-IO-Compress-Base

           Removing: perl-IO-Compress-Base-2.020-119.el6_1.1.x86_64
(@anaconda-CentOS-201112091719.x86_64/6.2)

               perl-IO-Compress-Base = 2.020-119.el6_1.1

           Obsoleted By: perl-IO-Compress-2.037-1.el6.rfx.noarch
(rpmforge-extras)

               Not found

Error: Package: perl-IO-Compress-2.037-1.el6.rfx.noarch
(rpmforge-extras)

           Requires: perl(Compress::Raw::Zlib) = 2.037

           Installed: perl-Compress-Raw-Zlib-2.051-1.el6.rfx.x86_64
(@rpmforge-extras)

               perl(Compress::Raw::Zlib) = 2.051

           Available: perl-Compress-Raw-Zlib-2.023-119.el6_1.1.x86_64
(base)

               perl(Compress::Raw::Zlib) = 2.020

           Available: perl-Compress-Raw-Zlib-2.030-1.el6.rfx.x86_64
(rpmforge-extras)

               perl(Compress::Raw::Zlib) = 2.030

           Available: perl-Compress-Raw-Zlib-2.033-1.el6.rfx.x86_64
(rpmforge-extras)

               perl(Compress::Raw::Zlib) = 2.033

           Available: perl-Compress-Raw-Zlib-2.034-1.el6.rfx.x86_64
(rpmforge-extras)

               perl(Compress::Raw::Zlib) = 2.034

           Available: perl-Compress-Raw-Zlib-2.035-1.el6.rfx.x86_64
(rpmforge-extras)

               perl(Compress::Raw::Zlib) = 2.035

           Available: perl-Compress-Raw-Zlib-2.037-1.el6.rfx.x86_64
(rpmforge-extras)

               perl(Compress::Raw::Zlib) = 2.037

Error: Package: perl-core-5.10.1-119.el6_1.1.x86_64
(@anaconda-CentOS-201112091719.x86_64/6.2)

           Requires: perl-Compress-Zlib

           Removing: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64 (@base)

               perl-Compress-Zlib = 2.020-119.el6_1.1

           Obsoleted By: perl-IO-Compress-2.037-1.el6.rfx.noarch
(rpmforge-extras)

               Not found

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

 

My notes say to first uninstall perl-Compress-Zlib, then install
perl-IO-Compress but this isn’t working this time. Does anyone have a
suggestion?

Best regards,

Fred

Fred Kienker
fkienker at at4b.com
P: 770.518.6166

AT4B
5261 Sunset Trail
Marietta, GA 30068

"Advanced Technologies for Business"

This transmission may contain information that is privileged,
confidential and/or exempt from disclosure under applicable law. If you
are not the intended recipient, you are hereby notified that any
disclosure, copying, distribution, or use of the information contained
herein (including any reliance thereon) is STRICTLY PROHIBITED. If you
received this transmission in error, please immediately contact the
sender and destroy the material in its entirety, whether in electronic
or hard copy format. Thank you.

 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/users/attachments/20120504/bbe50726/attachment-0002.html>


More information about the users mailing list