[users] perl-IO-Compress conflict with rpmforge extras enabled

Ned Slider ned at unixmail.co.uk
Fri May 4 17:21:14 CEST 2012


On 04/05/12 14:18, Fred Kienker wrote:
> The old perl-IO-Compress conflict error has reappeared. I’m installing
> CentOS 6.2 Base and have the rpmforge-extras enabled. When I run “yum
> update” I get:
>
>
>
> * base: mirror.teklinks.com
>
> * extras: mirrors.bluehost.com
>
> * rpmforge: apt.sw.be
>
> * rpmforge-extras: apt.sw.be
>
> * updates: mirror.fdcservers.net
>
> Setting up Update Process
>
> Resolving Dependencies
>
> -->  Running transaction check
>
> --->  Package perl-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
> obsoleted
>
> -->  Processing Dependency: perl-Compress-Zlib for package:
> perl-core-5.10.1-119.el6_1.1.x86_64
>
> --->  Package perl-IO-Compress.noarch 0:2.037-1.el6.rfx will be
> obsoleting
>
> -->  Processing Dependency: perl(Compress::Raw::Bzip2) = 2.037 for
> package: perl-IO-Compress-2.037-1.el6.rfx.noarch
>
> -->  Processing Dependency: perl(Compress::Raw::Zlib) = 2.037 for
> package: perl-IO-Compress-2.037-1.el6.rfx.noarch
>
> --->  Package perl-IO-Compress-Base.x86_64 0:2.020-119.el6_1.1 will be
> obsoleted
>
> -->  Processing Dependency: perl-IO-Compress-Base for package:
> perl-core-5.10.1-119.el6_1.1.x86_64
>
> --->  Package perl-IO-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
> obsoleted
>
> -->  Processing Dependency: perl-IO-Compress-Zlib for package:
> perl-core-5.10.1-119.el6_1.1.x86_64
>
> -->  Running transaction check
>
> --->  Package perl-Compress-Raw-Bzip2.x86_64 0:2.037-1.el6.rf will be
> installed
>
> --->  Package perl-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
> obsoleted
>
> -->  Processing Dependency: perl-Compress-Zlib for package:
> perl-core-5.10.1-119.el6_1.1.x86_64
>
> --->  Package perl-IO-Compress.noarch 0:2.037-1.el6.rfx will be
> obsoleting
>
> -->  Processing Dependency: perl(Compress::Raw::Zlib) = 2.037 for
> package: perl-IO-Compress-2.037-1.el6.rfx.noarch
>
> --->  Package perl-IO-Compress-Base.x86_64 0:2.020-119.el6_1.1 will be
> obsoleted
>
> -->  Processing Dependency: perl-IO-Compress-Base for package:
> perl-core-5.10.1-119.el6_1.1.x86_64
>
> --->  Package perl-IO-Compress-Zlib.x86_64 0:2.020-119.el6_1.1 will be
> obsoleted
>
> -->  Processing Dependency: perl-IO-Compress-Zlib for package:
> perl-core-5.10.1-119.el6_1.1.x86_64
>
> -->  Finished Dependency Resolution
>
> Error: Package: perl-core-5.10.1-119.el6_1.1.x86_64
> (@anaconda-CentOS-201112091719.x86_64/6.2)
>
>             Requires: perl-IO-Compress-Zlib
>
>             Removing: perl-IO-Compress-Zlib-2.020-119.el6_1.1.x86_64
> (@anaconda-CentOS-201112091719.x86_64/6.2)
>
>                 perl-IO-Compress-Zlib = 2.020-119.el6_1.1
>
>             Obsoleted By: perl-IO-Compress-2.037-1.el6.rfx.noarch
> (rpmforge-extras)
>
>                 Not found
>
> Error: Package: perl-core-5.10.1-119.el6_1.1.x86_64
> (@anaconda-CentOS-201112091719.x86_64/6.2)
>
>             Requires: perl-IO-Compress-Base
>
>             Removing: perl-IO-Compress-Base-2.020-119.el6_1.1.x86_64
> (@anaconda-CentOS-201112091719.x86_64/6.2)
>
>                 perl-IO-Compress-Base = 2.020-119.el6_1.1
>
>             Obsoleted By: perl-IO-Compress-2.037-1.el6.rfx.noarch
> (rpmforge-extras)
>
>                 Not found
>
> Error: Package: perl-IO-Compress-2.037-1.el6.rfx.noarch
> (rpmforge-extras)
>
>             Requires: perl(Compress::Raw::Zlib) = 2.037
>
>             Installed: perl-Compress-Raw-Zlib-2.051-1.el6.rfx.x86_64
> (@rpmforge-extras)
>
>                 perl(Compress::Raw::Zlib) = 2.051
>
>             Available: perl-Compress-Raw-Zlib-2.023-119.el6_1.1.x86_64
> (base)
>
>                 perl(Compress::Raw::Zlib) = 2.020
>
>             Available: perl-Compress-Raw-Zlib-2.030-1.el6.rfx.x86_64
> (rpmforge-extras)
>
>                 perl(Compress::Raw::Zlib) = 2.030
>
>             Available: perl-Compress-Raw-Zlib-2.033-1.el6.rfx.x86_64
> (rpmforge-extras)
>
>                 perl(Compress::Raw::Zlib) = 2.033
>
>             Available: perl-Compress-Raw-Zlib-2.034-1.el6.rfx.x86_64
> (rpmforge-extras)
>
>                 perl(Compress::Raw::Zlib) = 2.034
>
>             Available: perl-Compress-Raw-Zlib-2.035-1.el6.rfx.x86_64
> (rpmforge-extras)
>
>                 perl(Compress::Raw::Zlib) = 2.035
>
>             Available: perl-Compress-Raw-Zlib-2.037-1.el6.rfx.x86_64
> (rpmforge-extras)
>
>                 perl(Compress::Raw::Zlib) = 2.037
>
> Error: Package: perl-core-5.10.1-119.el6_1.1.x86_64
> (@anaconda-CentOS-201112091719.x86_64/6.2)
>
>             Requires: perl-Compress-Zlib
>
>             Removing: perl-Compress-Zlib-2.020-119.el6_1.1.x86_64 (@base)
>
>                 perl-Compress-Zlib = 2.020-119.el6_1.1
>
>             Obsoleted By: perl-IO-Compress-2.037-1.el6.rfx.noarch
> (rpmforge-extras)
>
>                 Not found
>
> You could try using --skip-broken to work around the problem
>
> You could try running: rpm -Va --nofiles --nodigest
>
>
>
> My notes say to first uninstall perl-Compress-Zlib, then install
> perl-IO-Compress but this isn’t working this time. Does anyone have a
> suggestion?
>
> Best regards,
>
> Fred
>

It's a known issue and the fix is already in the pipeline:

https://github.com/repoforge/rpms/issues/159

Hold tight, it should sort itself out in due course.




More information about the users mailing list