[users] Trac dependency error on CentOS 6.3 / new version

Georg Sauthoff mail at georg.so
Wed Feb 13 22:20:29 CET 2013


Hi,

I've enabled the rpmforge repositories an a fresh minimal CentOS 6.3 and
the install of the rpmforge trac package fails:

# yum install trac
[..]
---> Package trac.noarch 0:0.12-3.el6.rfx will be installed
--> Processing Dependency: python-sqlite2 for package: trac-0.12-3.el6.rfx.noarch
--> Processing Dependency: mod_python for package: trac-0.12-3.el6.rfx.noarch
--> Finished Dependency Resolution
Error: Package: trac-0.12-3.el6.rfx.noarch (rpmforge-extras)
           Requires: mod_python
Error: Package: trac-0.12-3.el6.rfx.noarch (rpmforge-extras)
           Requires: python-sqlite2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Also, the latest stable release of Trac is 1.0.1 - thus, a package upgrade in
rpmforge would be great.

Btw, the EPEL-repository contains Trac 0.12, too - yum install it from there
does not yield a dependency resolution error.

Also, trac does not need to depend on mod_python - for many usecases
running it via 'tracd' is enough - i.e. no need for mod_python/apache.

Best regards
Georg


More information about the users mailing list