[users] php-mcrypt (from php-extras) mcrypt.ini file is incorrect

Todd Lyons tlyons at ivenue.com
Mon May 20 20:53:37 CEST 2013


On Mon, May 20, 2013 at 5:42 AM, Leon Fauster
<leonfauster at googlemail.com> wrote:
> Am 20.05.2013 um 11:58 schrieb Richard Lloyd <rklloyd at gmail.com>:
>> The php-mcrypt 5.3.3-1 package (created from the php-extras src rpm) from repoforge.org appears to have an incorrect /etc/php.d/mcrypt.ini file. The equivalent package from Fedora EPEL (yes, it's also available there!) says:
>> ; Enable mcrypt extension module
>> extension=mcrypt.so
>> But the repoforge version at http://apt.sw.be/redhat/el6/en/x86_64/dag/RPMS/php-mcrypt-5.3.3-1.el6.rf.x86_64.rpm incorrectly says:
>> ; Enable mcrypt extension module
>> extension=module.so
> Repoforge has nothing to do with EPEL - therefore such "incompatibilities" can exist. Repoforge
> is considered as 3rd party repository. It is best practice to not mix 3rd party repos.

He's not saying that RepoForge is the same as EPEL.  He's saying that
the RepoForge mcrypt package puts the wrong configuration setting in
the mcrypt.ini file, whereas the EPEL version puts the correct
configuration setting.  He's requesting that RepoForge mcrypt php
package be fixed to have the correct module name in the mcrypt.ini
file so that php can actually find the correct shared object when it
looks for it.

...Todd

--
The total budget at all receivers for solving senders' problems is $0.
 If you want them to accept your mail and manage it the way you want,
send it the way the spec says to. --John Levine


More information about the users mailing list