[users] perl-ExtUtils-MakeMaker

Nico Kadel-Garcia nkadel at gmail.com
Tue Feb 4 12:58:35 CET 2014


On Mon, Feb 3, 2014 at 9:24 AM, Rob Redpath <rob.redpath at wwwh.com> wrote:
> Hi,
>
> I'm probably being an idiot, but I'm experiencing something odd with
> perl-ExtUtils-MakeMaker. I'm building an RPM that needs a more recent
> ExtUtils::MakeMaker than the one provided with my distribution (CentOS 5.9),
> so I went searching for a suitable RPM, finding one on repoforge. However,
> while the file exists on pkgs.repoforge.org (
> http://pkgs.repoforge.org/perl-ExtUtils-MakeMaker/ ), it doesn't appear to
> be available through any of the repoforge repos for my distribution -
> rpmforge, rpmforge-extras or rpmforge-testing. I've checked that it's not an
> issue with my local yum installation - the package isn't present in the XML.
>
> What am I missing?
>
> Thanks
>
> Rob

CentOS 6? I'm not sure of the specific issues with this package, but
it's very difficult to keep your CPAN modules up to date with the
latest dependencies if you're working on a core OS that is 7 years
old. It will eat an ever increasing amount of your time to try and
keep Perl components updated. Been there, done that, got the
consulting fees.

Now, if you just need more recent contemporary packages for CentOS 6,
I've got a build toolchain for RT 4 over at
https://github.com/nkadel/rt4repobuilder/. A number of those
components *do* upgrade built-in CentOS packages, so much of it would
have to go in rpmforge-extras. much as I would expect
perl-ExtUtils-MakeMaker to go there. But there's scertainly a working
source package for perl-ExtUtils-Maker.


More information about the users mailing list